What did I take off? - VW Forum :: Volkswagen Forum
Midwestern US Minnesota, Iowa, Wisconsin, Illinois, Kentucky, Indian, Michigan

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 06-21-2019, 11:43 PM Thread Starter
Member
Points: 4, Level: 1 Points: 4, Level: 1 Points: 4, Level: 1
Activity: 33% Activity: 33% Activity: 33%
 
Join Date: Jun 2019
Posts: 1
What did I take off?

So I work in Walmart in their TLE and I had a 2012 Volkswagen Jetta come in for an oil change. Now I’m not familiar with any VW car so I was relying off our oil guides and filter guides. Our filter guide said the car took a canister filter a fram 3614 if I remember correctly. I go under the car to change the filter and don’t see a canister type filter anywhere but I see what looked like a housing for a cartridge type filter. Now this was attached to a gray box that didn’t seem to connect to anything. I start removing it and oil just pours out and it doesn’t have a filter on it. I tried to put it back on and I could not get it to go back in and screw into place. Took another guy about 10-15 minutes to get it back on. Filled it up with oil and checked if it was leaking from there and there were no leaks. Anyone have any idea what this was?
Hendo52496 is offline  
Sponsored Links
Advertisement
 
Reply

  VW Forum :: Volkswagen Forum > VW Regional Talk > Midwestern US

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the VW Forum :: Volkswagen Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome