VW Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Having a problem while driving my 2004 Beetle 2.0. The car just dies like losing all function of gas pedal with no acceleration at all . Then in 2 secs it picks back up as if nothing happened. Have total loss of power, no idiot lights, Vag Scan shows nothing. It's like you turn the key off then back on. I have now changed coil - plugs - and cam sensor. Still no fix. Could it be the pump in the tank? Or fuel relay? If anyone has had this problem please post!
Thanks
MT
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
Fuel filter has been changed and throttle body and MAF has been cleaned. I forgot to list that in first post. No the electrical power does not go. It has all power as far as electrical goes. It seems to happen when tank is about 1/4 full.
MT
 

·
Registered
Joined
·
1 Posts
04 vw beetle

I am having the same problem as you are except now when its been driven for a time it also stalls when trying to accelerate. Have you been able to correct the problem?
 

·
Registered
Joined
·
4 Posts
Discussion Starter #5
No fix yet. I have been keeping the tank above 1/8 and it is fine. I have had it stall a few times after running a while. Only at a signal or stop. Have to put in N and restart. Other times I was going 70 MPH at about 3,000 RPM on an incline and the power just drops off and the Tach goes down to 900 RPM's then I have to shift the trans to Sports mode and it kicks back up to 3,000RPMs and all is fine. It does not die when the car is on the Freeway.
I know someone has the answer. So I will keep the tank full till someone posts an answer!
MT
 

·
Registered
Joined
·
22 Posts
My 99 1.8t is doing the exact same thing. I jumped on the forum to find out if anyone else is having this problem and low and behold sure enough another is having the same problem.
At about 3k rpm its like the fuel has been cut off. No warning lights nothing. Do beetles have two fuel pumps? An intank boost pump that feeds the main pump? I have had other cars that acted like this when the boost pump crapped out and the fuel level was below 1/4 tank. I am pointing fingers at fuel feed issues.
I am also having some alarm issues and was thinking maybe the alarm is malfunctioning and shutting the car off. Recently replaced the MAF sensor and had the water pump and timing belt replaced but the problem surfaced about a month after this work was done.

Do beetles have a primer fuel pump in the gas tank that feeds the main pump?

I had a Volvo that when the fuel level went below 1/4 level the engine would sometimes die because the fuel was not being drawn out of the tank down to the main pump.
 

·
Registered
Joined
·
1 Posts
My 2004 Beetle did the same thing. At first, it was rare & as long as the take was over 1/4 it was fine. But then it began happening more frequently with loss of acceleration for longer amounts of time. Took it in two different times & they couldn't get it to fail, so just kept tank over a 1/4. (The fuel filter was already replaced, & lines were flushed previously... neither fixed the problem.) Last weekend, it had 1/2 tank & failed going uphill on the Grapevine and never really regained acceleration... it would sputter in & out. Since it's a standard shift, it would stall. Filled the tank and it ran with no problems. Took it back to VW and they still couldn't get it to fail, so they replaced the fuel pump. So far, no problems. Will keep you updated.
 

·
Registered
Joined
·
3 Posts
Replace in this order to find fault. Fuel pressure regulator----fuel pump relay-----fuel pump. it's the regul;ator 80% sure
 

·
Registered
Joined
·
1 Posts
this can be caused by stuck brake light switch, did you get recall notice? I have had the problem (04 jetta 2.0) occasionally ....found on other threads...that a sticking brake causes the throttle to back off....I was out today proving the case....you can provoke this same behavior by lightly touching the brake while keeping steady gas pedal...after about 2 sec th rpms will drop and the throttle will not respond for a sec or 2 then will resume normal behavior...try this before diving deeper into other solutions
 

·
Registered
Joined
·
22 Posts
this can be caused by stuck brake light switch, did you get recall notice? I have had the problem (04 jetta 2.0) occasionally ....found on other threads...that a sticking brake causes the throttle to back off....I was out today proving the case....you can provoke this same behavior by lightly touching the brake while keeping steady gas pedal...after about 2 sec th rpms will drop and the throttle will not respond for a sec or 2 then will resume normal behavior...try this before diving deeper into other solutions
Wow! This is interesting. No solution yet on my problem. No fuel delivery issues, no codes and no other malfunctions can be found. Randomly acts like fuel is being shut off. Also feels like something a fail safe would do.
Why not, I am out of guess's. Might as well replace the switch and see if that cures it.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #11
OK! It's Fixed!

OK! It's Fixed!!!!!!!!!!
It was the fuel pump. So if you have any questions feel free to contact me.
REPLACE THE FUEL PUMP FIRST!!!!!
 

·
Registered
Joined
·
1 Posts
Fuel pump relay problem

OK! It's Fixed!!!!!!!!!!
It was the fuel pump. So if you have any questions feel free to contact me.
REPLACE THE FUEL PUMP FIRST!!!!!
+++

Hi there, thank you for your thread - I am joining in from Denmark and I have a similar problem.

Where do I find the fuel pump and not the least the relay? I have a VW New Beetle 2,0 from '99. Engine type AGY.

Thanks in advance for your support
 

·
Registered
Joined
·
1 Posts
05 Beetle

I have the same issue. I have purchased two fuel filters one with a pressurized regulator something that makes it 47 dollars?, and also a standard fuel fuel without pressurized regulator for 15 dollars. I am very unfamiliar with what type I may need as I have no manual for my beetle. (Last year at the dealer I spent over 600 dollars allowing them to remove oil pan and remove sludge ? Said the previous owner did not get regular oil changes.) So now this is happening seems to be fuel related? The filters I bought do not look like they replace the current dealer stock models ? Do I need to also purchase these from VW ? Also, I noticed that it appears there is a filter near front of car and one in the rear. I think at this point I need to purchase a manual, or chilton any suggestions on the above would be most appreciated!
Thanks so much!
Char
 

·
Registered
Joined
·
46 Posts
Hi Guyz.
I also have a vw Beetle 2.0 that dies while driving and the petrol is at 1/4 tank. Once it stops then i start it up again then drive off. After a couple of kilos at dies again. I have changed the coil, the petrol filter and the petrol pump however the problem is still there. Anyone that can help me with this problem?
 
1 - 14 of 14 Posts
Top