VW Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
My 2002 VW GTI VR6 started running a little rough before it was warmed up. Recently the "EPC" light has come on intermittently. Now I can't go over 2500-3000 rmp without total loss of power.

Any Ideas? Suggestions? I've done a little reading is it my coil pack?

Should I not be driving the car?
 

·
Registered
Joined
·
169 Posts
Yes it could be bad coil, relay, speed sensor, ALT Etc. I found this a long the way hope it helps.

EPC refers to the drive by wire system. This system, generally speaking, encompasses the throttle pedal and its position sensors (it needs to know where your gassin' foot is) and the throttle body.

Most likely, the EPC light and its associated faults for this scenario are a symptom, not the problem. Meaning the actual root cause is causing the no-start/no crank issue AND fault codes related to the EPC system.

And the most likely root cause is an ignition switch, NOT the engine speed sensor.

With a bad engine speed sensor, the car will still crank all damn day (or until the battery dies) but the car won't start.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #3
Thanks Juan. I broke down and brought it to certified vw mechanic. It ended up being the crank posistion sensor. Between that and the diagnosis he wants $565. Kind of crazy for such an easy fix but my after market stereo caused problems with his original diagnosis.
 

·
Registered
Joined
·
169 Posts
Wow that hurts,,,, you should be able to do it your self its good to pamper your car on your own once in a while ;)
 
1 - 4 of 4 Posts
Top