VW Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I have a 90 Jetta with 140,000 miles. The engine and tranny run great on this car but I am having a few nagging problems that I hope some of you have encountered also.

#1 - After the engine has warmed up (20 min drive) the oil warning light will come on whenever the rpms drop below 2000. Usually only in the high gears though. Like when I am in 5th gear and for some reason i let off the gas a little, as soon as it drops to 2000 rpm the light will buzz. So i either have to hit the gas or down shift to shut it up. Same deal for 4th and 3rd gear usually. Any clues?

#2 - After driving the car for a normal ride (10-20 mins) when I shut the car off the engine cooling fan continues to run for about 15 mins. Any clues?

Thats about it. The other problems I can fix (Valve cover gasket leak, and a shot temperature gauge). Oil levels are fine and all other fluids are fine. If anyone has had similar problems on their VW's please give me an email back.

[email protected]

Thanks, Ryan
 

·
Registered
Joined
·
349 Posts
hey man hope these help a little bit.

#1 it sounds to me that you have a bad oil pump. maybe even just a bad oil pressure sensor. when you first start the car, the oil has a higher viscosity than after it has been running for a while. my first suggestion would be to replace the oil pressure sensors, one on the top of the oil filter, and one on the right side of the head. if that doesnt take care of the problem then it is the oil pump.

#2 the radiator fan should stay on for a couple of minutes but not 15. i would say that it is a bad temperature switch located on the driver's side of the radiator. it's a simple fix that should cost about $25 to repair from your local parts store.

hope this helps a little bit and let me know how you make out
 

·
Registered
Joined
·
125 Posts
#1 - After the engine has warmed up (20 min drive) the oil warning light will come on whenever the rpms drop below 2000. Usually only in the high gears though. Like when I am in 5th gear and for some reason i let off the gas a little, as soon as it drops to 2000 rpm the light will buzz. So i either have to hit the gas or down shift to shut it up. Same deal for 4th and 3rd gear usually. Any clues?

sorta off topic, but why would you be in fifth gear and below 2000 rpm?
 

·
Registered
Joined
·
2,513 Posts
your fan is run constsant, meening ignition doesn't need to be on for it to work. It goes by temperature so it'll run as long as it has to until the temperature drops below the determined temp. I don't know the actual temp. It won't hurt anuthing. I agree with bluemk2 about the oil pump or sensor. Should probably be one of them. Change the sensor first. It's most likly cheaper. Good luck.
 

·
Registered
Joined
·
573 Posts
My 91 Jetta takes forever to warm up as well, though I usualy start running it after 2 minutes of idle waiting. I've yet to have any problems performance-wise, but the temp reading is usually showing on the cold side of the gauge, even after driving for a long time. And I drive my car hard. Anyone think this is a problem? Any advice?
 
1 - 7 of 7 Posts
Top