VW Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Hey guys,

Ive got a 94 Jetta III and the Ac seems to be not working properly. Last summer I refilled the freon in the system and the AC stayed decently cold all summer. This summer is a different story. I refilled the freon again and now when I turn it on it gets really cold for a minute or two and then the air starts to come out hot. Any ideas on what needs fixed?
 

·
Registered
Joined
·
54 Posts
Is it possible that your clutch could be bad? or you may have a bad pressure switch. Open your hood and turn on your AC and listen to the compressor. Since it works, listen to the clutch. If it turns off and does not come back on, It is probably the pressure switch. My switch was bad, and it had a leak. I too have a 1994 Jetta 2.0L 5 speed Almost 180K miles. Good luck. Or when you messed with your system you could have possibly added too much R134a, causing the pressure switch to do its job...
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
I know it's not that there is too much coolant in the system, I added it 1 can at a time over the course of 3 weeks, and only put 2 cans in. I'll try listening to the clutch, where was your switch located?
 

·
Registered
Joined
·
54 Posts
Front passenger side under the front of car. Pain in the a** to get to on gravel. You have to remove a couple weather shields to get to it. If there was any R134a in your system before you added the two cans it is too full. Two cans is close to the max.
 
1 - 4 of 4 Posts
Top