VW Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
55 Posts
Discussion Starter #1
Well it seems like I just keep running in to problems on the 04 gli I just bought. Tonight I was heading to work and when I turned off my street to the main road (left) the ECS light came on and stayed on. Note that I didn't get on the car causing the ecs to engage. Well I tryed pushing the ecs button on the dash and nothing would happen, the light just stayed on the dash.

So whats going on here?

Just a back story on this though. When I bought the car a couple of weeks ago i noticed that the inner boot for the cv joint was ripped and needed to be replaced so I replaced it. Ofcourse I removed the axle to replace the boot and I'm wondering if that could have something to do with it.

The car doesn't seem to be in limp mode or anything, it seems to be running fine actually I just believe that the ecs is off.
Any help asap would be greatly appreciated
 

·
Registered
Joined
·
3,144 Posts
i had the ecs light pop on for a while. it eventually went away. it hasnt come back for about 2 years. it doesnt show up in scans.

pretty sure my abs wires at one of the wheels was torn. check anyways.
 

·
Premium Member
Joined
·
6,954 Posts
Could be abs sensor at wheel. Abs module, faulty wire connector. Lots of things. If you have access to a vag-com you can open the abs blocks and hand spin each wheel while lifted and verify the sensors are registering. That will give you which wheel sensor/wiring to go after.

Also could be wheel bearing failure or hub ring failure making sensor not read slots in hub ring properly. Hard to diagnosis off the limited info you offered.
 

·
Premium Member
Joined
·
4,466 Posts
trac control and anti lock use the same sensor.
You likely pulled one and not the other. The car only needs one sensor to use abs properly, it's not a system like a modern mercades that has variable braking per wheel, it lowers the braking force to the whole master cyl and thus all 4 brakes.

Just lift the car, pull the wheel off where you did the axle and take a look at the sensor. The wires pull out very easily you could do it without noticing.
 

·
Registered
Joined
·
55 Posts
Discussion Starter #7
i had the ecs light pop on for a while. it eventually went away. it hasnt come back for about 2 years. it doesnt show up in scans.

pretty sure my abs wires at one of the wheels was torn. check anyways.
So are you still able to turn the esc off and on with the dash button?
 

·
Premium Member
Joined
·
4,466 Posts
Pressing the ESC button will turn it off, which will show the light. If the light is already showing that wont show a difference.
 

·
Registered
Joined
·
55 Posts
Discussion Starter #9
Pressing the ESC button will turn it off, which will show the light. If the light is already showing that wont show a difference.
no I was asking if he would have stability control back after having the light on so long, or did the dash light just go out and the stability control not come back.
 

·
Registered
Joined
·
3,144 Posts
So are you still able to turn the esc off and on with the dash button?
when the light is on, you can press the ESC button as much as you want, but the light just stays lit. Idk if it was actually turning it on and off, but either way, the light stays on.
 
1 - 10 of 10 Posts
Top