VW Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
252 Posts
Discussion Starter #1
Ok yesterday I drove my car to work everthing was fine drove home from work..fine. I go to drive it to walmart and my check engine light comes on for no reason that I can tell. I have 38k miles, nuespeed p-flow, and supersprint 2 1/2 catback exhaust, its not like I have a lot of modds. I have noticed latly when I get on it and shift from 2nd to 3rd and 3rd to 4th its back firing, (my exhaust normally gurgals a little bit)but now it have one definate pop when I do this. Other than this the car sounds like its running fine, I'm not sure if the check engine light and this are related I'll be taking to the dealer on Monday. If anyone knows whats going on let me know. Again I'll be taking it in on Monday so I'll let you guys know what the problem is if ur interested.

[ March 06, 2004: Message edited by: Wug ]
 

·
Registered
Joined
·
1,228 Posts
Does p flow void your warranty? If so, they'll probably blame it on that but if not, they'll probably fix it.
 

·
Registered
Joined
·
736 Posts
check out ur MAF, and make sure ur intake is clean and on properly
 

·
Registered
Joined
·
252 Posts
Discussion Starter #5
Thanks for the reply guys. I know it isn't from the filter because I never oiled it before (probably will soon at like 45k)I checked around the filter making sure it didn't slip off the intake. I was thinking it maybe the maf and I'd have to clean it, but again never oiled the filter why would it be dirty...possibly going bad..wouldn't I notice a performance difference?
If the dealship is going to be a d*ck and blame it on the p-flow and try and charge me for them to hook-up a vag com I'll just be a d*ck back and have them do the 40k checkup (they hook the vag com up at 40k and check codes anyway)
Well I just decided to reset the ecu took off postive and negative from battery waited 10 min hooked it back up let the car idle for 5 minutes to relearn. I watched it while it was idling and I only drove it from the back of my house around the block but, so far no more check engine light. I think I really need to run the car for at least 15 mins to say it's fixed. I'll let you guys know what happens if the light comes back on again its getting parked and going to the dealer on Monday. Bad dubs get time out.

[ March 06, 2004: Message edited by: Wug ]
 

·
Registered
Joined
·
4,993 Posts
Without knowing what code its throwing, I can't really help you...checking the gas cap is a good start, as mentioned above.
 

·
Registered
Joined
·
252 Posts
Discussion Starter #8
Well here is and update guys. After I reset my ecu the chech engine light came back on a few days later. Well had them read the code and I was told it was a malfunctioning temp sensor. Would have never known that with out running a vag com.

Also I heard Auto zone will check engine codes for free. Anyone here of this?
 

·
Registered
Joined
·
8,124 Posts
Yep, they will scan the codes but they wont tell you what they mean. Post them on here and we will be able to tell you what they mean.
 

·
Registered
Joined
·
252 Posts
Discussion Starter #10
sweet I have the bently manual its describes codes in there right?
 

·
Registered
Joined
·
223 Posts
well two weeks ago my check engine came on buddy and I had a VW tech that i know come with his labtop come n check it out comes out that it was the COOLANT temperature sensor too he told me its under the waranty. so i go in the next day where he works and he works for autobarn where I purchesed my car the guys in there told him supervisors tell him this tell him that so the can charge me not knowing that we are friends fackin dealership anyway I got it fuxed under the waranty. they said to charge me cuz my car is modded out but the buddy hooked it up no charge.
 
1 - 12 of 12 Posts
Top