VW Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
380 Posts
Discussion Starter #1
ok heres the problem.

today i was painting my interior and the vent frames and so on. Then i decided to paint the gauge cluster also. After I had finished everything, I turned on my car and the Airbag light came on. Is this a serious problem? Can it be turned off without having to go to the dealership? Is this covered by my Warranty?(its a 2001 Golf)
Thanx for all the help

Emir
 

·
Registered
Joined
·
423 Posts
Did you unplug the cluster itself??

Did you take the steering wheel off to get the cluster out of the dash??

If you unplugged the cluster the aig bag diag monitor might have picked up a voltage spike or a voltage drop. There shouldn't be a problem with the SRS system, but you probably will have to bring it to the dealer, so they can erase the code.

SRS = Supplement Restraint System
(Air bag system)
 

·
Registered
Joined
·
3,658 Posts
Also try to disconnect the Negative wire of your Batt. for at lease ten min. this will reset the ECU.
jon
 

·
Registered
Joined
·
380 Posts
Discussion Starter #4
Yes i did unplug the cluster itself. I had to since i needed to get the plastiglass cover off and paint the inside. I didnt take of my steering wheel. I hope its just that spark as you said. If not then im goin to the dealer. Is this covered or will i have to pay?"
 

·
Registered
Joined
·
7,718 Posts
yeah. like jon said, just unplug your neg to your battery for like10-15 minutes, should reset the codes for you. give it a shot before you pay $50+ to have vw reset them for you.
 

·
Registered
Joined
·
3,658 Posts
It varies from dealer to dealer. I paid 30 for them to reset mine when i got an oil change at the same time.
jon
 

·
Registered
Joined
·
380 Posts
Discussion Starter #8
but it should be covered i mean its not my fault lol. I think as long as its under the warranty they should pay but then again u guys paid. I hope its not much. Tx for the help.

Emir
 

·
Registered
Joined
·
3,658 Posts
They will say "Since you took the cluster cover off, you voided the warrenty for this repair."
jon
 

·
Registered
Joined
·
380 Posts
Discussion Starter #10
how will they know that caused the problem. I can say that I had painted that 2 years ago and today was the first time I had a problem with it. They can't know when i painted it. Oh well i disconnected the battery its sitting there for now. If nothin happens im off to the dealer. I need an oil change anyways. Thanx Guys

Emir
 

·
Registered
Joined
·
1,638 Posts
they would fix it for free if it just came on. but since you took off your cluster they may tell you that you caused it. or if anyone around you has a vagcom, just have them meet you somewhere and reset the code for you. btw you have any pics of your painted dash? i wanna see
 

·
Registered
Joined
·
380 Posts
Discussion Starter #12
i will post pics tonight Rich. I just got back from the dealership and since i know a guy that works in the service department he told me it might be a blown fuse. He will see what he can do. Tomorow is my apointment at 10am. Oilchange, Clutch grease-up, and turning of that stoopid light. The squeeking clutch has been bothering me for quite a while, tx god its getting lubed up.

Emir
 
1 - 12 of 12 Posts
Top