VW Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
33 Posts
Discussion Starter #1 (Edited)
Headlight switch is causing turn signals not to work

When I put on my turn signals, they do not engage unless I wiggle the headlight switch. Does the wiring connect to the headlight switch harness?

I originally had this problem two years ago but everything started working again. Didn't have to fix anything... Now its back.

It has been really moist and foggy outside as well in the morning which causes the lights to not work as often, but during the day they sometimes work.

The emergency 4 way flashers stop working when the turn signals stop working as well. Is there a way to diagnose this issue? Im going to take the headlight switch out and see if there is any loose connections. Also might try and hunt down the turn signal relay.

Any help much appreciated.
 

·
Registered
Joined
·
137 Posts
Do your windshield wipers work properly as well or do those cut in and out sometimes? How about your fan controls? Its a good idea to start with your headlight switch to find the issue, but if that doesn't fix the problem it could be an issue with your ignition switch. Especially something in your case that could be explained as "gremlins"
 

·
Registered
Joined
·
33 Posts
Discussion Starter #3
My windshield wipers works well. My fan control on the number 3 fan speed setting does not work. If I hold the fan switch off 3 a tad, it will work. Could this be related?

The ignition switch is only 3 years old. The Headlight switch was a used one I installed from a wrecker about 2 years ago. The light on the the headlight switch always flickers but never caused any problems that I know of.

I will check the headlight switch tomorrow. I didn't think they were wired with the signal controls.
 

·
Registered
Joined
·
137 Posts
Your fan switch acting strangely probably has to do with the little metal tab on the inside of the dial that makes contact and tells it what speed to be set to. If you were to take it apart and bend the tab a little bit it would probably be fine. Sounds like the headlight switch is goofy
 

·
Registered
Joined
·
33 Posts
Discussion Starter #6 (Edited)
Thanks for all the info. I have been busy and haven't had a chance to take it apart.

I noticed that the signal lights work when I use my windshield wipers. The signals may be picking up power or ground from the wipers.

I don't want to replace parts till I make a diagnosis.

Also I will see if I can fix the fan control, thanks for that tip!
 

·
Registered
Joined
·
33 Posts
Discussion Starter #7 (Edited)
Problem solved! :D

My signals started acting like brake lights which has happened in the past. Turns out the newer ground wire I soldered to the brake light circuit board had gotten hot again and loosened the connection by melting the solder. I resoldered the wire back on better and everything works good again.

Also, my 3rd brake light was rusted and full of water so I disconnected its wiring harness till I get a replacement. Might be the cause for the short.
 
1 - 7 of 7 Posts
Top