VW Forum banner

21 - 22 of 22 Posts

·
Banned
Joined
·
19 Posts
The speedometer and RPM will shut down and indicate 0. Sometime it will happen while driving and come back to life later, or it will not come back at all. Sometimes it will come back after shut down and sometime not. When it goes blank- even the milege goes blank!

Don't know if they're related....A few Showbox jiofi.local.html tplinklogin months back the clocked started to reset to incorrect times after shut downs. No matter how many time I set the time, after shut down and restart the clock will show a different time.

Is there a fuse or relay or something for the instrument gauges?...or is my instrument panel going bad?

Thanks
My solution lately has been to hit the top of the dash and they flick back on(which definitly leads me to believe it is a connection issue). the only guage I would really like to work all the time is temp. For now Im just going to live with it and not drive over any bumps until I have time to rebuild my 2.slo next summer.
 

·
Registered
Joined
·
1 Posts
The speedometer and RPM will shut down and indicate 0. Sometime it will happen while driving and come back to life later, or it will not come back at all. Sometimes it will come back after shut down and sometime not. When it goes blank- even the milege goes blank!

Don't know if they're related....A few months back the clocked started to reset to incorrect times after shut downs. No matter how many time I set the time, after shut down and restart the clock will show a different time.

Is there a fuse or relay or something for the instrument gauges?...or is my instrument panel going bad?

Thanks
Hello
Might be better to have your original part repaired at upfix.com

Here is the service link
 
21 - 22 of 22 Posts
Top