VW Forum banner

1 - 20 of 23 Posts

·
Registered
Joined
·
138 Posts
Discussion Starter #1
I was accelerating on the highway and all of a sudden there was smoke everywhere. My car completely loss power. I came to a stop. Oil is dripping under the car. There's oil in the back of the engine bay.

What happened? How screwed am I?
 

·
Registered
Joined
·
28 Posts
if oil is at the back of the bay i would guess oil lines to the turbo, as to how fucked you are depends on how far you tried to drive afterwards. check ur turbo lines
 

·
Registered
Joined
·
962 Posts
Lucky you didn't have a fire.
 

·
Registered
Joined
·
138 Posts
Discussion Starter #5
It's being towed to the shop now. I am not looking foward to tomorrow.

Possible scenarios?
 

·
Registered
Joined
·
278 Posts
Blown bearings in the turbo, or the whole turbo itself. Spun bearings on the crank, cam, or piston wrist pins, smoked rings on the pistons, burned valves. If you do have it fixed, make sure they replace the oil pump, if it went dry at all and didn't fail, it will soon and then it will do more damage. An ounce of prevention is worth a pound of cure.
 

·
Registered
Joined
·
1,194 Posts
Blown bearings in the turbo, or the whole turbo itself. Spun bearings on the crank, cam, or piston wrist pins, smoked rings on the pistons, burned valves. If you do have it fixed, make sure they replace the oil pump, if it went dry at all and didn't fail, it will soon and then it will do more damage. An ounce of prevention is worth a pound of cure.
As posted abv, there are many scenerio's but hopfully its only the turbo oil line.
 

·
Registered
Joined
·
138 Posts
Discussion Starter #8
Just talked to the garage. They are lifting it up now. Will keep posted.
 

·
Registered
Joined
·
138 Posts
Discussion Starter #10
Blew a rod in the engine. Had to buy a whole new engine. Changed the clutch while I was at it. Broke for a long time...
 

·
Registered
Joined
·
316 Posts
best thing to do would be to do the rods while you are at it idk if the car is stock but at about 300hp or 300tq and with a good hard curve programmed you will keep having the same problems so i would say get some inigrated todes all for for about 400
 

·
Registered
Joined
·
138 Posts
Discussion Starter #13
I was stock. I'm not really modding my GLI. I do the modding on my Sky. I just want a reliable fun sport compact. My sky is plenty fast and I don't believe in +200hp in a fwd car anyways.
 

·
Registered
Joined
·
138 Posts
Discussion Starter #17
So I picked up my car and it feels slower than it did before. Any ideas?
 

·
Knows nothing about VWs
Joined
·
6,954 Posts
BAd plugs, gapped wrong, vac leak, clogged cat, brakes improperly bleed and sticking, crappy compression on the new engine, you "were" chipped wtihout your knowledge and it went into stock mode when the engine was replaced and power cutoff to the ECU for a period ot time....(I call this the 96GTIVR6 is a lucky SOB and stumbles upon GIAC scenerio) ;-)

possibilities are limitless man, sorry i can't help out much on that....do you have a boost gauge and know what you "were' boosting?
 

·
Registered
Joined
·
138 Posts
Discussion Starter #19
I don't have a boost gauge. However I did call and confirm that an AWP was correctly put in and he reused the ECU.
 

·
Registered
Joined
·
138 Posts
Discussion Starter #20
I went and tried the APR method of seeing if there was a tune by holding the set of the cruise control. Anything else I could try?
 
1 - 20 of 23 Posts
Top