VW Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
Ok, I bought this car two days ago. Besides an oil leak (that started at the oil pressure sender apparently, everything was fine.

I am having a few minor problems though, and if I could get some help I would really appreciate it.

First, the speedometer and tachometer only work 10 percent of the time.
Second, the brakes seem to vibrate under my foot, but the car stops fine.

Thanks everyone.
 

·
Premium Member
Joined
·
603 Posts
the vr6s are nice...i would love to do a motor swap for my 2.0....the oil leak you will want to check and get rid of right away...whether it is big or small...big its going to lower your pressure and you will be spending lots on oil...if its small it can cause issues later...

For your meters it sounds most likely something in your gauge cluster...i would first just try pulling the ground off the battery and leave it for half and hour then try it...sometimes all it needs is a hard reset...if not you might have a bad cluster :S

Might need to have your rotors done to get rid of that vibration...a mechanic will have to do that..unless you have machine work experience.
 

·
Premium Member
Joined
·
965 Posts
First, the speedometer and tachometer only work 10 percent of the time.
this is known as the p0hantom gauge problem. my VR has it too. you can have it fixed by a guy on vortex or you can get a new (used) cluster and replace it.

Second, the brakes seem to vibrate under my foot, but the car stops fine.
warped rotors.
 

·
Premium Member
Joined
·
965 Posts
i don't know what it would take to repair it yourself, you need parts from germany iirc. you can get a used vr cluster for prob no more than $50.
 
1 - 6 of 6 Posts
Top