VW Forum banner

1 - 20 of 25 Posts

·
Registered
Joined
·
76 Posts
Discussion Starter #1
My buddie had a low mile 2.0 motor from a 98 so I whent and got a strait bodied 96 gl with a blown cylender and did a swap. Now that it's rollng I'm stating to think of mods for it. Just wondering if it's worth my time money blood sweat and tears.

Starting with the tint, sound system and I already have a cherry bomb exaust.
But I'm wondering what to do next and what brands would be the bigst bang for my buck. Here are what some vw guys have suggestd.

Air intake ofcourse. Figured a k&n

heard that an oversized cam would push 10-15 more hp

suspension, I have no clue on brands, prob less than 1,500 bucks.

I have some tsw 17's that look sick but are road dashed way bad from a crash on pass side, prob need some new ones

and new poly bushings


If youguys could give me some tips and suggestions that would be sweet

oh and it's black, treck edition
 

·
Registered
Joined
·
366 Posts
all i can say is search man. this topoc has been covered 74898268846 times.

i have a thread in here called the 2.slow thread...should help you out

dont drop to much into that motor, it isnt worth it

as for suspension. i like h&r or eibach. get some lowering springs, nice struts "kyb is suggestion for cheepo's", swaybars, and poly bushings...strut tower braces if you wanna waist a few bucks
 

·
Registered
Joined
·
76 Posts
Discussion Starter #4
Ya I read all of that thanks, gave me some ideas

Then what kind of bushings to you suggest?

As doom as I get somthing done I'll post pics, might be a while
 

·
Premium Member
Joined
·
2,664 Posts
Well poly bushings are a great upgrade and pay off in many ways. Just know there will be some squeeking.
 

·
Registered
Joined
·
366 Posts
Ya I read all of that thanks, gave me some ideas

Then what kind of bushings to you suggest?

As doom as I get somthing done I'll post pics, might be a while
when you do bushing rup some dieelectric grease on the contact points....no noise
 

·
Registered
Joined
·
76 Posts
Discussion Starter #7
Ya that's what I wouldve guessed. Thanks guys
 

·
Registered
Joined
·
76 Posts
Discussion Starter #8
Y so I've been looking at cold air intakes and k&n drop in filters, I have a question. When looking at the neuspeed website and there cold air set up they refer to an stock air pump, what is this part? I can't think of anything like this on my car. Thanks for any help
 

·
Premium Member
Joined
·
965 Posts
its hard to get substantially low on 17s. my last gti came with 17s on coils and i c rubbed with them all the way up and it looked like a 4x4.
 

·
Registered
Joined
·
76 Posts
Discussion Starter #12
The parts car I have came with those road rashed 17s and it rode fine before it got totaled, never rubbed at all, idk how low it was though
 

·
Premium Member
Joined
·
2,664 Posts
i lowered mine like 2.5-3 inchs and i do rub on bumps but thats it. i got real low for 17's. This is how my car sits, cant go much lower than i am.

 

·
Registered
Joined
·
366 Posts
its hard to get substantially low on 17s. my last gti came with 17s on coils and i c rubbed with them all the way up and it looked like a 4x4.
+1 my black mk3 is rolling on 17's and dropped 3 inches

rubs effing everywhere! and it looks really crappy IMO...do some short and fat 15's. thats what im about to do and it looks effing SICK
 

·
Premium Member
Joined
·
2,664 Posts
I barely rub at all, my front lip rubs more than my tires. You guys must have bouncy suspension cause my tire barely rubs. And you cant even put your fingers between the fender and my tire.
 

·
Registered
Joined
·
76 Posts
Discussion Starter #16
So I spent some money and put in some tunes

new pioneer deck
4 infinity 6032cf 6.5s for the doors and rear, powered by a kicker 4ch 500 w
mtx 12" sub with matching mono 600w amp

no idea how it sounds yet, gettn it grounded after work today
 

·
Registered
Joined
·
76 Posts
Discussion Starter #17
So when I droped the new 2.slow in my clutch engaged realy early, and wouldn't even engage fully when my foot was off the petaland would slip if I accelerated too fast, but I know the clutch is in good condition. I know these clutches are supposed to auto adjst but when I pressed to petal 5 times in neutral I didn't notice any change. To temporarily solve the problem I just took out the rubber spacer on the clutch cable were it connects to the clutch arm on the tranny. I'm jst wondering if there was a slight differance in cable length between diff years, or if somthing else is causing this problem. Without the rubber spacer it grabbs a lil late but functions. Just tryn to make sure I don't mess up anything
 

·
Registered
Joined
·
366 Posts
cable could be stretched out...if thats the case it is junk

check the finger that runs your throw out bearing also. they break all the time
 

·
Registered
Joined
·
76 Posts
Discussion Starter #19
Ok well I'll swap the cable for the one in my parts car, and do some searchn on that throwout Bering finger
 

·
Registered
Joined
·
12 Posts
well... first of all i cant believe you guys are fightin about who's lower.

second. does ur pedal have any free play? if not then ur pedals hangin ur clutch up. was it a bitch to get the cable on?
 
1 - 20 of 25 Posts
Top