VW Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
26 Posts
Discussion Starter #1
He there,

I bought this car about a year ago for my wife and it has been really reliable. this is the first problem:

When the car is on or off/ Hot or cold/ the radiator fan stays on. I wanted to know if this is a know problem with the Jetta 1.8's?

I called a VW place and they said it was problay the radiator fan switch that is located under the radiator on drivers side.
I bought one and wanted to know if I'm on the right track.

I like this forum layout!!
I'm a member of Preludeonline.com, since I love my Prelude


Also think the "nudespeed" advirtisment is pimp as hell
 

·
Registered
Joined
·
2,513 Posts
First off welcome to the forum. Secondly the fan is run constant so once it hits a certain temperature it'll run until it cools to a certain temperature whether the ignition is on or off. Mine used to set the alarm off all the time. But if you wanna go with a new fan switch then get a neuspeed or another company that sells a lower temp fan switch. And fix it right thefirst time ya know what i mean. Goodluck and let us know how it turns out.
 

·
Registered
Joined
·
26 Posts
Discussion Starter #3
Ok I got it fixed:
It was the rad fan switch. It was very easy to take out except for a plastic dimple on the radiator that prevented me from getting to the bolt/Nut with my channel locks.

But anyways a quick write up for replacing:
1.Take battery cables off
2.Remove battery
3.Look at Drivers lower corner of radiator
there will be a plug that has a wire
connector. Pull connector off.
4.Easiest way to take off would be with a deep socket(between 21-23mm). Since I was working at my apt and not my dads shop then the lower radiator fan support will need to come off to get the Channel locks in.
5.When you loosen the sensor all the way out
coolant will come out FAST. so have the new sensor with THE GASKET ON to plug and put in the hole


do everything else in reverse and youre good to go.

WHY I DID THIS- My fan never shut off hot or cold engine. this was a fault of the radiator fan switch. Cost me $26.99 at schucks. If it the fan NEVER came on I suppose this switch could also cause that be problay is either the fan motor or the relay.
Possibly the wiring or connectors.
 
1 - 3 of 3 Posts
Top