VW Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
37 Posts
Discussion Starter #1
My Jetta has a very rough idle when I first start it up. The colder the temperature is outside the worse it gets. The check engine light is on but I did a cat delete awhile back. I had assumed that it was the MAF but I just replaced it with a new Bosch from ECS with it doing the same thing. Trying to figure out what the issue might be. Here's a list of the aftermarket stuff. 2.5 DP with no cat Megan Racing version, 2.5 in cat back exhaust, and a K&N drop in air filter. I do not have access to someone with vagcom. Trying to find someone with it in my area but no luck so far. Engine is a 1.8T AWW engine code
 

·
Registered
Joined
·
128 Posts
Buy a cheapy cable off ebay? Or get a generic scanner for like $20-$30. Can't help you out much if you can't give us codes. The only possible thing I can see is the post cat O2 sensor is going crazy cause the cat is gone. If your willing to throw money at it try buying a 90 degree O2 extender and slap it in there. I have a 3" Tsudo turbo back and it tripped off my rear O2 until I put that in. The K&N filter might be messing up the MAF if it has oil residue on it from what I recall reading on other post. Try unplugging it to see if it runs better. Check your spark plugs if they're clean. Change out your coolant temp sensor to a green top. Change out your crankshaft position sensor if that hasn't been done. Seafoam it from your brake booster line while your at it if your in the mood to smoke up your neighborhood. This is all about throwing money at it until you give us codes.
 
1 - 3 of 3 Posts
Top