VW Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Found my 2003 Passat wagon driver side floor full of (rain) water this morning. Bad things were happening: light wouldn't turn off, alarm going off, signal lights both on................ect.
Disconnected the battery (maybe I shouldn't have done this?) cleaned up most of the water to allow some drying time. What should I do next?
Thanks:confused:
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3
don't have a sunroof,
Is there anything I need to know before connecting the battery? I thought I read somewhere it could mess up the computer??
 

·
Registered
Joined
·
169 Posts
Not sure about this but, is the comfort control ECU under the floor boards on the drivers side. I know that on some earlier Passats thats where it was located and if water gets in there it's good bye ECU. I could be wrong about your model year, like I said just not sure.

Ainokea
 

·
Registered
Joined
·
517 Posts
Open the hood and remove the entire plastic cover over the battery and brake booster. There are 2 drains there. They are probably clogged.

One is under the battery, one is under the brake booster/master cylinder.

It's a very common problem with Passats.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #7
Open the hood and remove the entire plastic cover over the battery and brake booster. There are 2 drains there. They are probably clogged.

One is under the battery, one is under the brake booster/master cylinder.

It's a very common problem with Passats.
Thanks I'll try that, connected the battery and it starts runs fine, But the Horn/alarm is still going off, windows won't move, key fob won't work
what now??
 

·
Registered
Joined
·
517 Posts
Remove the drivers seat, pull the carpet back and remove he comfort module. Inspect the wire harness for broken wires or rotted connections.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #9
Got a new comfort control ECU, having a problem programing to make the horn beep when I unlock the rear hatch, ( it worked before the ECU problem)
suggestions?
 
1 - 10 of 10 Posts
Top