VW Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
526 Posts
Discussion Starter #1
my right turn doesnt work when my lights are on because its in full glow when i put the lights on..it doesnt blink or do anyting its just on...any ideas on what the hell it is...the holder for the light is fine and the wires are all there?
 

·
Registered
Joined
·
203 Posts
well first thing that i would do is check the fuses and replace any second that i would suggest is that you take the bulb out of the holder check for any corrosion inside of it then third. turn your turn signal on and then go and wiggle the light around in the bulb holder if the light comes on and blinks then you should pry the contacts of the bulb holder out a little bit to where they touch the metal on the bulb.
 
G

·
Guest
Joined
·
0 Posts
could be the blinker wire could have worn through and now it's bare on the body of the car....thats why it's grounding out now...check the wires to see if there bare..
 

·
Registered
Joined
·
203 Posts
i got a question for ya.
when your lights are Off and you put your turn signal on does it blink really fast or does it blink really slow??

i would say that if it blinks really slow you should try replacing the bulb even if its not broken. While you have the bulb out of the bulb holder you should try bending the metal contacts inside the bulbholder out a litle to where they touch the bulb.(<----- best to do when the lights are on and the turn signal on.)

if it blinks really fast check all wiring going to and from the bulb like montana green said one of the wires may be worn through or one of them might be disconnected and grounding out on the car.
 

·
Registered
Joined
·
92 Posts
check the bulb in the other end of the car . my rabbit would not work if there was a one way bulb in the opposite end of the car
 

·
Registered
Joined
·
526 Posts
Discussion Starter #7
there was a one way there but i replaced it with a 2 way cuz the person who put them in didnt know any better. and no the blinker is fine and not blinking fast when the lights are off. the front bulbs are fine too. i have a feeling its something behind the dash or my turn signal and wiper stalk. i tried putting a different head light switch in but that didnt work either. and its like u turn the ligths on and the bottom two light up like they shoudl but then, and this is only on the right side, the turn signal one lights up and just stays lit

[ July 16, 2003: Message edited by: vlksgnspeed ]
 

·
Registered
Joined
·
111 Posts
I know this sounds really stupid, but when I had my car I had to replace the turn signal bulb because it burnt out. Now I had the same problem you are having. Upon further inspection, I realized that the bulb was in the wrong way. I some how had put the higher end knob on the lower end side (you know, the two little knobs or knibs or whatever you want to call them on the bulb that slide into the socket.) I turned the bulb and put it in correctly and some how it worked right. Don't know if that makes ANY sense, but it worked.

Another possibility on a related matter, as a possibility on what fixed my problem, is to check your hazard switch. Make sure that the hazard switches connections in the dash are tight. I noticed I had loose connections on the hazard switch too when I was having signal and hazard problems.

If those don't fix it I suggest parking your car at the top of a hill, putting it in neutral and then releasing the E-brake. Won't fix your problem but at least you wont have to worry about it anymore.
 

·
Registered
Joined
·
4 Posts
97 Cabrio fast blinking turn signal

When I purchased my 97 Cabrio the right turn signal was blinking really fast. The solution to that is to replace the lamp (bulb) socket and it will work properly. The socket had corroded due to moisture in the turn signal lens.:K:
 
1 - 10 of 10 Posts
Top